CAAD

Comunidad de Aventuras Conversacionales y Relatos Interactivos
Fecha actual 25 Ene 2021 16:00

Todos los horarios son UTC + 1 hora




Nuevo tema Responder al tema  [ 13 mensajes ] 
Autor Mensaje
NotaPublicado: 14 May 2008 07:24 
Inferno 0.1 acaba de salir:


Inferno es un recubrimiento de txtMap, hecho en Java, que permite utilizar al mapeador de una manera muy intuitiva, visual y directa.

Inferno viene ya con todo para empezar a desarrollar en Inform. Inferno es un entorno que permite fácilmente crear una aventura a partir de una descripción realizada a modo de juego. Una vez satisfecho con el resultado (que se puede ir verificando mediante su visión en un navegador), es posible generar el código, y en el caso de I6 e I6Sp, trabajar directamente en este entorno, bien hasta el final de desarrollo, bien hasta que el trabajo tenga algo más de madurez (y entonces utilizar Jit o Wide).

Inferno es ideal para principiantes, pues es capaz de generar las habitaciones y objetos de una aventura en varios sistemas, incluyendo I6, I6Sp, I7, I7Sp, y a otros españoles como Superglús, Kenshira, AGE e InformATE!.

Más información en la página del proyecto.


Arriba
  
 
 Asunto:
NotaPublicado: 14 May 2008 07:26 
Desconectado
xyzzy

Registrado: 09 Mar 2004 22:50
Mensajes: 9150
He publicado la noticia en la portada del CAAD, a pesar de estar ya posteada en el foro, porque creo que esta novedad es de interés general.

Saludos
Jenesis


Arriba
 Perfil  
 
NotaPublicado: 14 May 2008 15:17 
Desconectado
Samudio
Samudio
Avatar de Usuario

Registrado: 10 Sep 2004 00:17
Mensajes: 3102
Ubicación: Chile
Al ejecutar Inferno.jar recibo un error del Java VirtualMachine Launcher que dice "Could not find the main class. Program will exit".

What the f...? :oops:

_________________
[Incanus] - Sígueme en itch.io
El Escritorio - Blog Aventurero y Literario


Arriba
 Perfil  
 
NotaPublicado: 14 May 2008 17:36 
Desconectado
Betatester
Betatester
Avatar de Usuario

Registrado: 22 Sep 2004 09:33
Mensajes: 1100
Incanus escribió:
Al ejecutar Inferno.jar recibo un error del Java VirtualMachine Launcher que dice "Could not find the main class. Program will exit".

What the f...? :oops:


Hola Incanus,

Solo por si no lo estás haciendo así. En la linea de comandos:

Código:
java -jar inferno.jar


Saludetes
Mapache


Arriba
 Perfil  
 
NotaPublicado: 14 May 2008 17:38 
Desconectado
Betatester
Betatester
Avatar de Usuario

Registrado: 22 Sep 2004 09:33
Mensajes: 1100
Incanus escribió:
Al ejecutar Inferno.jar recibo un error del Java VirtualMachine Launcher que dice "Could not find the main class. Program will exit".

What the f...? :oops:


Hola Incanus,

Solo por si no lo estás haciendo así. En la linea de comandos:

Código:
java -jar inferno.jar


Saludetes
Mapache


Arriba
 Perfil  
 
NotaPublicado: 14 May 2008 17:55 
Desconectado
Betatester
Betatester
Avatar de Usuario

Registrado: 22 Sep 2004 09:33
Mensajes: 1100
Incanus escribió:
Al ejecutar Inferno.jar recibo un error del Java VirtualMachine Launcher que dice "Could not find the main class. Program will exit".

What the f...? :oops:


Hola Incanus,

Solo por si no lo estás haciendo así. En la linea de comandos:

Código:
java -jar inferno.jar


Saludetes
Mapache


Arriba
 Perfil  
 
 Asunto:
NotaPublicado: 14 May 2008 19:54 
Desconectado
Momio
Momio
Avatar de Usuario

Registrado: 09 Mar 2004 16:14
Mensajes: 4659
Creo que no lo ha dicho nadie aún:

java -jar inferno.jar

XD


Arriba
 Perfil  
 
 Asunto:
NotaPublicado: 14 May 2008 22:12 
Desconectado
xyzzy

Registrado: 09 Mar 2004 22:50
Mensajes: 9150
Uto escribió:
Creo que no lo ha dicho nadie aún:

java -jar inferno.jar

XD


Jo... con razón no me funcionaba correctamente... :roll:
Yo es que ejecutaba el "inferno_unix.ini" y se lanzaba el ide, pero claro... notaba yo que faltaba algo. Son las cosas de que en Linux cualquier cosa pueda ser un ejecutable. :lol:
Pues gracias, ahora por fin he conseguido tener algo en story objects!!!

Saludos
Jenesis


Arriba
 Perfil  
 
NotaPublicado: 15 May 2008 15:05 
Desconectado
Samudio
Samudio
Avatar de Usuario

Registrado: 10 Sep 2004 00:17
Mensajes: 3102
Ubicación: Chile
No daré la lata...
No daré la lata...
No daré la lata...

(ya pa-pa-pa-parezco po-po-po-Porky) :-P

[spoiler="...pero el error sigue"]
Código:
D:\temp\IF\Inferno>java -jar inferno.jar
Exception in thread "main" java.lang.UnsupportedClassVersionError: Bad version n
umber in .class file
        at java.lang.ClassLoader.defineClass1(Native Method)
        at java.lang.ClassLoader.defineClass(Unknown Source)
        at java.security.SecureClassLoader.defineClass(Unknown Source)
        at java.net.URLClassLoader.defineClass(Unknown Source)
        at java.net.URLClassLoader.access$100(Unknown Source)
        at java.net.URLClassLoader$1.run(Unknown Source)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(Unknown Source)
        at java.lang.ClassLoader.loadClass(Unknown Source)
        at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
        at java.lang.ClassLoader.loadClass(Unknown Source)
        at java.lang.ClassLoader.loadClassInternal(Unknown Source)

D:\temp\IF\Inferno>
[/spoiler]

Así que, de nuevo: What the f...? :?

_________________
[Incanus] - Sígueme en itch.io
El Escritorio - Blog Aventurero y Literario


Arriba
 Perfil  
 
 Asunto:
NotaPublicado: 15 May 2008 15:11 
Desconectado
Momio
Momio
Avatar de Usuario

Registrado: 09 Mar 2004 22:29
Mensajes: 1592
Ubicación: R.I.P.
Citar:
Desde Java SE 1.2 se dispone de la excepción java.lang.UnsupportedClassVersionError. La cual nos avisa que la JVM intenta leer un fichero class cuya version (mayor o minor) no está soportada.

java.lang.UnsupportedClassVersionError, hemos compilado con una versión de Java mayor a la versión que esta ejecutando en la JVM.


O sea, tienes que actualizar tu JRE.

Por eso es tan importante, en aplicaciones Java, especificar la versión mínima del JRE requerida.

Si instalas con el nuevo instalador, que al parecer se ha currado Baltasar, debería avisarte de este problema y ofrecerte un enlace para descargar la versión correcta.

_________________

"Tengo tres perros peligrosos: la ingratitud, la soberbia y la envidia. Cuando muerden dejan una herida profunda. (Martín Lutero)"


Arriba
 Perfil  
 
 Asunto:
NotaPublicado: 15 May 2008 15:26 
Desconectado
Implementador
Implementador

Registrado: 18 Mar 2004 19:26
Mensajes: 1482
Ubicación: Barcelona
Hablando de spanglish y por si no había quedado claro...

Código:
Javajarinfernojaring is a verb aplying to one thing.
Understand "java -jar inferno.jar " as javajarinfernojaring.
Before javajarinfernojaring:
say "Ahora ya puedes usar Inferno" instead;
rule succeeds.

_________________
https://asvelin.itch.io/


Arriba
 Perfil  
 
 Asunto: Inferno
NotaPublicado: 15 May 2008 17:02 
Desconectado
Semimomio
Semimomio
Avatar de Usuario

Registrado: 23 Abr 2004 08:49
Mensajes: 2996
Ubicación: España (Galicia)
Hola !

JSJ escribió:
O sea, tienes que actualizar tu JRE.
Por eso es tan importante, en aplicaciones Java, especificar la versión mínima del JRE requerida.


La versión mínima supongo que sería la 1.4, aunque como lo he hecho con la 1.6, es probable que requiera ésta, que es la última. De todas formas, pensaba que la mayor parte de la gente tenía el Java actualizado, ya que ahora hasta se actualiza el solo periódicamente.

Citar:
Si instalas con el nuevo instalador, que al parecer se ha currado Baltasar, debería avisarte de este problema y ofrecerte un enlace para descargar la versión correcta.


Sí, el instalador seguro que avisa de eso (es una de las opciones que le metí). El instalador sólo no funciona cuando no hay ningún JRE disponible.

Jodé, qué cosas.

Salud !

Baltasar

_________________
-- Baltasar, el arquero


Arriba
 Perfil  
 
 Asunto: Re: Inferno
NotaPublicado: 15 May 2008 18:01 
Desconectado
Samudio
Samudio
Avatar de Usuario

Registrado: 10 Sep 2004 00:17
Mensajes: 3102
Ubicación: Chile
baltasarq escribió:
Jodé, qué cosas.


¡Ozú! Que ya actualizo la JRE ésa ¡y que me dé un copón por la falta de espe'icaciones de requetequisitos corre'tas, hombre!

_________________
[Incanus] - Sígueme en itch.io
El Escritorio - Blog Aventurero y Literario


Arriba
 Perfil  
 
Mostrar mensajes previos:  Ordenar por  
Nuevo tema Responder al tema  [ 13 mensajes ] 

Todos los horarios son UTC + 1 hora


¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 6 invitados


No puede abrir nuevos temas en este Foro
No puede responder a temas en este Foro
No puede editar sus mensajes en este Foro
No puede borrar sus mensajes en este Foro

Buscar:
Saltar a:  
cron
Desarrollado por phpBB® Forum Software © phpBB Group
Traducción al español por Huan Manwë para phpBB-Es.COM