CAAD

Comunidad de Aventuras Conversacionales y Relatos Interactivos
Fecha actual 16 Jul 2020 05:54

Todos los horarios son UTC + 1 hora




Nuevo tema Responder al tema  [ 85 mensajes ]  Ir a página Anterior  1, 2, 3, 4, 5, 6
Autor Mensaje
NotaPublicado: 12 Dic 2010 15:23 
Desconectado
xyzzy

Registrado: 09 Mar 2004 22:50
Mensajes: 9150
Al-Khwarizmi escribió:
jenesis escribió:
Al-Khwarizmi escribió:
Sí algo así tiene que ser, la pregunta es por qué lo hace con puck y no con aetheria o simpleage. :roll:


¿Seguro? ¿Lo estás haciendo exactamente igual? ¿No podría ser por ejemplo que PUCK lo tenías abierto antes de abrir Firefox y en cambio aetheria/simpleage los abres después? (o viceversa)


Después de ver que en Puck fallaban, he lanzado el aetheria y el simpleage y ambos funcionaban.
Y acabo de comprobarlo, de nuevo y funciona, solo falla el audio cuando visualizo un vídeo en youtube, el midi sigue sonando, pero no así el audio. Puedo seguir haciendo pruebas, pero no sé si merece la pena, porque se pueden dar multitud de situaciones y eso siempre confunde la lógica.

_________________
Si la mentira tuviera color, todos seríamos daltónicos...


Arriba
 Perfil  
 
NotaPublicado: 12 Dic 2010 15:39 
Desconectado
Samudio
Samudio
Avatar de Usuario

Registrado: 09 Mar 2004 16:16
Mensajes: 5312
Ubicación: Coruña
jenesis escribió:
Y acabo de comprobarlo, de nuevo y funciona, solo falla el audio cuando visualizo un vídeo en youtube, el midi sigue sonando, pero no así el audio. Puedo seguir haciendo pruebas, pero no sé si merece la pena, porque se pueden dar multitud de situaciones y eso siempre confunde la lógica.


Pero si estás viendo youtube entiendo que se trata del problema que ya conocíamos que hay para reproducir varias cosas a la vez en PulseAudio cuando una de ellas es java, flash, u otras aplicaciones (youtube es flash).

http://ubuntuforums.org/archive/index.p ... 18171.html
https://bugs.launchpad.net/ubuntu/+sour ... bug/209198

Esto es un problema general de la compatibilidad de Java, Flash y otras aplicaciones con PulseAudio y supongo que no se puede hacer más que esperar a que se resuelva solo en próximas versiones de PulseAudio.

_________________
Actúa siempre de tal modo que las decisiones de tu voluntad pudiesen servir como preceptos de una legislación universal (E. Kant)


Arriba
 Perfil  
 
NotaPublicado: 12 Dic 2010 15:43 
Desconectado
xyzzy

Registrado: 09 Mar 2004 22:50
Mensajes: 9150
Al-Khwarizmi escribió:
Pero si estás viendo youtube entiendo que se trata del problema que ya conocíamos que hay para reproducir varias cosas a la vez en PulseAudio cuando una de ellas es java, flash, u otras aplicaciones (youtube es flash).

http://ubuntuforums.org/archive/index.p ... 18171.html
https://bugs.launchpad.net/ubuntu/+sour ... bug/209198

Esto es un problema general de la compatibilidad de Java, Flash y otras aplicaciones con PulseAudio y supongo que no se puede hacer más que esperar a que se resuelva solo en próximas versiones de PulseAudio.


Sí, eso ya lo sé.
Pero tú querías datos y yo te los he dado.
Con firefox tanto aetheria como simpleage funcionan bien, a no ser que se esté usando un plugin de audio.

Otra cosa que ha cambiado es que ahora lo que falla en puck no es el midi, sino el audio, así que tal vez esto no tenga nada que ver con lo que ocurría anteriormente con el midi. O sí, a saber...

_________________
Si la mentira tuviera color, todos seríamos daltónicos...


Arriba
 Perfil  
 
NotaPublicado: 12 Dic 2010 15:46 
Desconectado
Samudio
Samudio
Avatar de Usuario

Registrado: 09 Mar 2004 16:16
Mensajes: 5312
Ubicación: Coruña
Ah, pero espera, entonces es que no entendí bien.

Con Firefox + plugin de audio entiendo que falla tanto con aetheria como con PUCK. Eso es lo que digo que es normal.

¿Pero con firefox *sin* plugin de audio, no falla con aetheria pero sí sigue fallando en PUCK? ¿Es eso?

_________________
Actúa siempre de tal modo que las decisiones de tu voluntad pudiesen servir como preceptos de una legislación universal (E. Kant)


Arriba
 Perfil  
 
NotaPublicado: 12 Dic 2010 15:51 
Desconectado
xyzzy

Registrado: 09 Mar 2004 22:50
Mensajes: 9150
Al-Khwarizmi escribió:
Ah, pero espera, entonces es que no entendí bien.

Con Firefox + plugin de audio entiendo que falla tanto con aetheria como con PUCK. Eso es lo que digo que es normal.

¿Pero con firefox *sin* plugin de audio, no falla con aetheria pero sí sigue fallando en PUCK? ¿Es eso?


Exactamente eso es. :)

_________________
Si la mentira tuviera color, todos seríamos daltónicos...


Arriba
 Perfil  
 
NotaPublicado: 12 Dic 2010 18:34 
Desconectado
xyzzy

Registrado: 09 Mar 2004 22:50
Mensajes: 9150
De todos modos mira esto:
Citar:
javax.sound.sampled.LineUnavailableException: line with format PCM_SIGNED 44100.0 Hz, 16 bit, stereo, 4 bytes/frame, little-endian not supported.
at com.sun.media.sound.DirectAudioDevice$DirectDL.implOpen(DirectAudioDevice.java:494)


audio+midi+noaudio
Este me lo está dando ahora tanto en puck como en aetheria/simpleage y seguramente está motivada por el hecho de que he estado editando archivos wav con audacity.
He mirado en google y me he encontrado con esto:

http://bugs.sun.com/bugdatabase/view_bu ... id=6714820

¿Podría tener relación con lo que pasa aquí?

_________________
Si la mentira tuviera color, todos seríamos daltónicos...


Arriba
 Perfil  
 
NotaPublicado: 12 Dic 2010 18:41 
Desconectado
xyzzy

Registrado: 09 Mar 2004 22:50
Mensajes: 9150
Añado algo a lo anterior.
A pesar de haber cerrado ya el puck y el simpleage, tenía dos procesos de java en marcha, los he matado y he vuelto a recuperar la funcionalidad.

Saludos

_________________
Si la mentira tuviera color, todos seríamos daltónicos...


Arriba
 Perfil  
 
NotaPublicado: 12 Dic 2010 21:02 
Desconectado
Samudio
Samudio
Avatar de Usuario

Registrado: 09 Mar 2004 16:16
Mensajes: 5312
Ubicación: Coruña
Podría tener que ver con el bug que has puesto, que dice ahí que está relacionado con suspender un portátil y reanudar (¿hiciste eso?) pero también podría ser lo de siempre, tema de aplicaciones ejecutándose a la vez... aunque ese error pone "format blablablá not supported", ya he comprobado alguna vez que también puede salir si la tarjeta de sonido no está disponible por algún motivo.

Habría que ver qué es lo que motiva que queden procesos de java abiertos después de cerrar el AGE, en teoría no deberían quedar abiertos. Tal vez haya algún bug ahí que no tenga que ver con el sonido... o tal vez no (igual Java abre un thread para pedir la tarjeta de vídeo, PulseAudio lo deja bloqueado y por eso queda ahí... a saber... estos fallos del audio linuxero son muy complicados)

_________________
Actúa siempre de tal modo que las decisiones de tu voluntad pudiesen servir como preceptos de una legislación universal (E. Kant)


Arriba
 Perfil  
 
NotaPublicado: 13 Dic 2010 11:49 
Desconectado
xyzzy

Registrado: 09 Mar 2004 22:50
Mensajes: 9150
He arrancado la Xubuntu de mi portátil y he probado la aventura.
Es desesperante, el sonido de los efectos se oye sobre los midis sin ningún problema y eso que realmente no están uno sobre otro, pero aún así todo funciona a la perfección.
Al final voy a pasar del pulseaudio y voy a dejar un aviso sobre la posibilidad de fallos en el audio a causa de su mala implementación en ubuntu. Me estoy cansando de pagar la incompetencia "altruista" de los gestores de ubuntu. :(

_________________
Si la mentira tuviera color, todos seríamos daltónicos...


Arriba
 Perfil  
 
NotaPublicado: 13 Dic 2010 14:08 
Desconectado
Samudio
Samudio
Avatar de Usuario

Registrado: 09 Mar 2004 16:16
Mensajes: 5312
Ubicación: Coruña
Ya... la verdad es que cuando Mark Shuttleworth empezó a gastar dinero en hacer publicidad de Ubuntu y mandar cedés a todo el mundo, aumentando la popularidad de Linux, yo me alegré (aunque use Windows porque me va mejor para las cosas que yo hago, me gustaría que un día Linux lo superara). Y la verdad es que en aquella época yo creo que era una distribución realmente buena (a mí nunca me gustó mucho porque se centraba en Gnome y yo soy más de KDE, pero en aquella época funcionaba muy bien).

Pero no sé qué bicho les ha picado en los últimos años, que ahora parece que es de las distribuciones más inestables. Hablando desde un lugar de trabajo donde hay instaladas y me toca manejar de vez en cuando Ubuntus, Debians, Suses y CentOSes, Ubuntu siempre es la que más problemas da. Y claro, como con toda esa publicidad que hicieron ha dejado la idea popular de que "ubuntu es el linux fácil de usar", la gente se lo cree, se lo instala, le da problemas por todas partes y luego sale diciendo "linux es un asco"... cosa que no es buena para Linux en general.

Pero bueno, mi objetivo sigue siendo que todo en AGE funcione bien en todos los sistemas operativos y distribuciones posibles, me gusten o no. Otra cosa es que si hay un problema subyacente que viene de capas inferiores y no del propio AGE, esto pueda ser imposible. Y en ese caso sí, tal vez no quede más remedio que conformarse con poner una advertencia en un readme (junto a un enlace a una página de las que enseñan a desinstalar PulseAudio :D)

_________________
Actúa siempre de tal modo que las decisiones de tu voluntad pudiesen servir como preceptos de una legislación universal (E. Kant)


Arriba
 Perfil  
 
Mostrar mensajes previos:  Ordenar por  
Nuevo tema Responder al tema  [ 85 mensajes ]  Ir a página Anterior  1, 2, 3, 4, 5, 6

Todos los horarios son UTC + 1 hora


¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 2 invitados


No puede abrir nuevos temas en este Foro
No puede responder a temas en este Foro
No puede editar sus mensajes en este Foro
No puede borrar sus mensajes en este Foro

Buscar:
Saltar a:  
cron
Desarrollado por phpBB® Forum Software © phpBB Group
Traducción al español por Huan Manwë para phpBB-Es.COM