CAAD

Comunidad de Aventuras Conversacionales y Relatos Interactivos
Fecha actual 28 Sep 2020 20:53

Todos los horarios son UTC + 1 hora




Nuevo tema Responder al tema  [ 3 mensajes ] 
Autor Mensaje
NotaPublicado: 17 Jul 2009 09:59 
Desconectado
xyzzy

Registrado: 09 Mar 2004 22:50
Mensajes: 9150
Tengo un problema de carga en un pentium IV a 2Ghz, y con 1 Gb de RAM, al que le cuesta 80 segundos cargar el mundo de mi proyecto, a veces hasta dos minutos.

He comprobado que en mi portátil a 1,5 Ghz, y con 500 mb de RAM le cuesta menos de la mitad, exactamente 36 segundos.
Ambas versiones de Java son las mismas y los enlaces al binario coinciden.

No tengo ni idea de a qué puede ser debido, he desinstalado todos aquellos paquetes que hacen referencia al java de Gnu, y también he desisntalado el Eclipse y algún programa relacionado con la edición de java y ya no se me ocurre que más hacer, después de hacer esto ha cargado (o eso me ha parecido) más rápido, he contado 48 segundos, pero en las siguientes pruebas ha tardado casi 2 minutos la primera vez y ha vuelto a los 80 el resto de veces.

He comprobado que en el portátil el tiempo de carga en lanzamientos consecutivos, se mantiene a 36 segundos, así que no parece ser un problema de liberación de recursos... ¿a alguien se le ocurre qué otra cosa puede ser?

Un saludo y gracias
Jenesis


Arriba
 Perfil  
 
 Asunto:
NotaPublicado: 17 Jul 2009 11:31 
Desconectado
Samudio
Samudio
Avatar de Usuario

Registrado: 09 Mar 2004 16:16
Mensajes: 5312
Ubicación: Coruña
Hmm, una pregunta, ¿usas el mismo sistema de ventanas (o sea, gnome, kde, etc.) en las dos máquinas? Se me ocurre que esto también podría influir, ya que como te dije hace tiempo lo que consume más tiempo de carga es crear (de una forma un poco chapucera) un formulario gráfico para cada objeto. (lo deseable sería usar proxies e inicialización "lazy" para sólo crear estos formularios cuando hace falta, pero mi prioridad era tener algo que funcionara, y esa optimización aún la tengo en la lista de cosas pendientes porque tiene su miga implementarla).

Por lo demás no sé qué podría ser... es normal que los tiempos de carga no sean ninguna maravilla por la limitación que he mencionado; pero que en un ordenador más rápido tarde más que en uno más lento es un misterio.

_________________
Actúa siempre de tal modo que las decisiones de tu voluntad pudiesen servir como preceptos de una legislación universal (E. Kant)


Arriba
 Perfil  
 
 Asunto:
NotaPublicado: 17 Jul 2009 11:37 
Desconectado
xyzzy

Registrado: 09 Mar 2004 22:50
Mensajes: 9150
Al-Khwarizmi escribió:
Hmm, una pregunta, ¿usas el mismo sistema de ventanas (o sea, gnome, kde, etc.)


Sí, y la misma versión de kernel y de gestor de ventanas, el Xfce.
Yo soy la primera sorprendida, y no es un tema que me quite el sueño porque aunque trabajo con el de sobremesa, todo se limita a hacer otra cosa mientras carga y ya está.
Pero el caso es que estoy intrigada y me gustaría saber cuál puede ser el problema, igual tiene algo que ver con la tarjeta gráfica y la gestión de los gráficos en las dos máquinas.
No te preocupes seguiré investigando pero tampoco está dentro de mis prioridades.

Un saludo


Arriba
 Perfil  
 
Mostrar mensajes previos:  Ordenar por  
Nuevo tema Responder al tema  [ 3 mensajes ] 

Todos los horarios son UTC + 1 hora


¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 4 invitados


No puede abrir nuevos temas en este Foro
No puede responder a temas en este Foro
No puede editar sus mensajes en este Foro
No puede borrar sus mensajes en este Foro

Buscar:
Saltar a:  
cron
Desarrollado por phpBB® Forum Software © phpBB Group
Traducción al español por Huan Manwë para phpBB-Es.COM