CAAD

Comunidad de Aventuras Conversacionales y Relatos Interactivos
Fecha actual 25 Jun 2017 15:02

Todos los horarios son UTC + 1 hora




Nuevo tema Responder al tema  [ 6 mensajes ] 
Autor Mensaje
NotaPublicado: 27 Ene 2017 15:10 
Desconectado
Enano Maluva
Enano Maluva
Avatar de Usuario

Registrado: 16 Nov 2016 12:05
Mensajes: 47
Buenas.
Estoy actualizando el código del intérprete de Level 9 y lo he colgado en github.

https://github.com/cibersheep/Level9

¿Qué funciona? (solo lo he podido probar en Ubuntu 16.04)
-Debería compilar solo texto
-He actualizado el Makefile y la versión que usa Gtk, con gráficos. Hay que instalar las librerías gtk2-dev
-Estoy actualizando el proyecto a Gtk3 y por ahora compila pero tiene un par de errores que no impiden jugar

¿Qué no funciona?
-La versión Glk. ¿Está pensada para ifp? Creo que es el mismo código que usa Gargoyle.
-La versión Unix... NPI por dónde ir.

¿Lista de deseos?
-Sería bonito ser capaz de llevarlo a qt. Que en teoría es fácil...

Imagen


Arriba
 Perfil  
 
NotaPublicado: 27 Ene 2017 23:22 
Desconectado
Enano Maluva
Enano Maluva
Avatar de Usuario

Registrado: 16 Nov 2016 12:05
Mensajes: 47
El Arquero me confirma que con MSYS se puede compilar en Windows sin problemas. ¡Bien!


Arriba
 Perfil  
 
NotaPublicado: 23 Feb 2017 12:56 
Desconectado
Enano Maluva
Enano Maluva
Avatar de Usuario

Registrado: 16 Nov 2016 12:05
Mensajes: 47
Actualización:
- Sabéis que ya se puede compilar la versión GTK2 y la GTK3 (aunque en esta última, todavía no he podido hacer que funcionen las opciones de color para el texto. El resto funciona a la mil maravillas)
- He aprovechado que quería investigar sobre los paquetes Snap de Ubuntu y he hecho uno con el intérprete. Que podéis bajaros desde la tienda, o con
Código:
sudo snap install level9
desde el terminal. Por ahora solo está para sistemas de 64 bits. He de seguir investigando para que esté disponible para sistemas ARM.
Vale para cualquier distribución GNU/Linux que soporte snapd.

Imagen


Arriba
 Perfil  
 
NotaPublicado: 24 Feb 2017 08:06 
Desconectado
Betatester
Betatester
Avatar de Usuario

Registrado: 27 Ene 2010 20:38
Mensajes: 1249
¿Está siendo mucho curro, CiberSheep?


Arriba
 Perfil  
 
NotaPublicado: 25 Feb 2017 09:53 
Desconectado
Semimomio
Semimomio
Avatar de Usuario

Registrado: 23 Abr 2004 08:49
Mensajes: 2876
Ubicación: España (Galicia)
Hola,

¡Mola!

-- Baltasar

_________________
-- Baltasar, el arquero


Arriba
 Perfil  
 
NotaPublicado: 25 Feb 2017 13:09 
Desconectado
Enano Maluva
Enano Maluva
Avatar de Usuario

Registrado: 16 Nov 2016 12:05
Mensajes: 47
Comely escribió:
¿Está siendo mucho curro, CiberSheep?

¿Pasar el código a snap? Ni lo más mínimo. Conseguir un paquete final ha sido un poco de prueba y error justamente por tener que añadir las librerías GTK. En resumen es hacer un archivo siguiendo el esquema y ya está.

Tengo pendiente hacer un minitutorial al respecto. cuando lo tenga os lo paso.

Mi idea original con el código del intérprete era poder hacerlo accesible desde cualquier dispositivo.
a) «emscriptándolo» para hacerlo funcionar en la web bajo javascript pero se me ha complicado un pelín :)
b) adaptándolo para que funcione con qt. Lo que se me complica un poco más.

baltasarq escribió:
Hola,
¡Mola!


Gracias. Un pasito «palante».


Arriba
 Perfil  
 
Mostrar mensajes previos:  Ordenar por  
Nuevo tema Responder al tema  [ 6 mensajes ] 

Todos los horarios son UTC + 1 hora


¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 1 invitado


No puede abrir nuevos temas en este Foro
No puede responder a temas en este Foro
No puede editar sus mensajes en este Foro
No puede borrar sus mensajes en este Foro

Buscar:
Saltar a:  
Desarrollado por phpBB® Forum Software © phpBB Group
Traducción al español por Huan Manwë para phpBB-Es.COM