CAAD

Comunidad de Aventuras Conversacionales y Relatos Interactivos
Fecha actual 21 Oct 2017 23:55

Todos los horarios son UTC + 1 hora




Nuevo tema Responder al tema  [ 12 mensajes ] 
Autor Mensaje
NotaPublicado: 09 Abr 2016 11:23 
Desconectado
Momio
Momio
Avatar de Usuario

Registrado: 09 Mar 2004 16:14
Mensajes: 4614
Hola,


Ayer abrí Superglús por primera vez en un tiempo, y por primera vez con Windows 10 como sistema operativo. El caso es que Superglús incluye el interprete Glulxe del pack Gargoyle como interprete por defecto, y me di cuenta de que no funcionaba. El interprete Git incluido en el mismo pack si que funciona, pero no se si es cosa mía o es un problema de Gargoyle en general. ¿A alguno le funciona bien en Win10 64bits? (ojo, Glulxe, no Git, se puede probar arrastrando un fichero blorb sobre el glulxe.exe del pack Gargoyle)

Podría cambiar Superglús para que llevara Git, ahora que Superglús es compatible con el mismo, pero me preocupa que todos los juegos antiguos de Superglús, al abrirlos con Gargoyle, que por defecto usa Glulxe para los .blb que genera Superglús, dejen de funcionar.

_________________
Sígueme en twitter: @uto_dev
http://www.ngpaws.com


Arriba
 Perfil  
 
NotaPublicado: 11 Abr 2016 16:51 
Desconectado
Betatester
Betatester
Avatar de Usuario

Registrado: 09 Feb 2012 20:33
Mensajes: 855
Hola Uto.

Yo tengo W10, y el interprete "glulxe.exe" de la descarga de superglus no me funciona. He probado con varias aventuras en .z5, .z8, .gblorb, y no llegan a arrancar.
Si funciona cuando abro superglus, una aventura de ejemplo y le doy a "compilar y ejecutar".

_________________
Te quiero... lo siento Yoda sólo tenemos café.


Arriba
 Perfil  
 
NotaPublicado: 11 Abr 2016 17:02 
Desconectado
Momio
Momio
Avatar de Usuario

Registrado: 09 Mar 2004 16:14
Mensajes: 4614
edlobez escribió:
Hola Uto.

Yo tengo W10, y el interprete "glulxe.exe" de la descarga de superglus no me funciona. He probado con varias aventuras en .z5, .z8, .gblorb, y no llegan a arrancar.
Si funciona cuando abro superglus, una aventura de ejemplo y le doy a "compilar y ejecutar".



Hmm... que cosa más rara. ¿Que tienes puesto en las opciones en el apartado del intérprete? (no sea que lo hayas cambiado para que use otro).

De todos modos parece confirmarse que ese glulxe no va en Windows 10 :-(

_________________
Sígueme en twitter: @uto_dev
http://www.ngpaws.com


Arriba
 Perfil  
 
NotaPublicado: 11 Abr 2016 18:02 
Desconectado
Betatester
Betatester
Avatar de Usuario

Registrado: 09 Feb 2012 20:33
Mensajes: 855
Pues sí es muy raro... algo debo estar haciendo mal, ya que el intérprete de superglus es "glulxe.exe" de la carpeta.

En las opciones de superglus...

Imagen



Arrastrando el "Anillo III" al ejecutable "glulxe.exe"




Imagen

_________________
Te quiero... lo siento Yoda sólo tenemos café.


Arriba
 Perfil  
 
NotaPublicado: 11 Abr 2016 19:45 
Desconectado
Momio
Momio
Avatar de Usuario

Registrado: 09 Mar 2004 16:14
Mensajes: 4614
Gracias por las pruebas.

Pues sí es raro. ¿Y simplemente ejecutar glulxe sin arrastrar nada?

A mi me da un error de esos de pete total de la app:

La aplicación no se pudo iniciar correctamente (0xc0000142). Haga clic en Aceptar para cerrarla.

Es decir, no hablo del típico error de "No ha selecionado un juego", sino un pete a más bajo nivel.

¿Puedes probar a ejecutar un .blb de Supeglús? (EL Ejercito de las tinieblas por ejemplo)

_________________
Sígueme en twitter: @uto_dev
http://www.ngpaws.com


Arriba
 Perfil  
 
NotaPublicado: 11 Abr 2016 22:26 
Desconectado
Betatester
Betatester
Avatar de Usuario

Registrado: 09 Feb 2012 20:33
Mensajes: 855
No, ese error tan chungo no me da. Ahora estoy en otro pc con W10, y me da el mismo error que me da en casa al ejecutar "glulxe.exe", me pide el nombre de la aventura a ejecutar.

Con respecto a ejecutar El ejercito de las tinieblas, se me ejecuta correctamente cuando lo arrastro al "glulxe.exe". Sin embargo no puedo ejecutar .z5, z8 ni blorb.

_________________
Te quiero... lo siento Yoda sólo tenemos café.


Arriba
 Perfil  
 
NotaPublicado: 12 Abr 2016 08:51 
Desconectado
Momio
Momio
Avatar de Usuario

Registrado: 09 Mar 2004 16:14
Mensajes: 4614
edlobez escribió:
No, ese error tan chungo no me da. Ahora estoy en otro pc con W10, y me da el mismo error que me da en casa al ejecutar "glulxe.exe", me pide el nombre de la aventura a ejecutar.

Con respecto a ejecutar El ejercito de las tinieblas, se me ejecuta correctamente cuando lo arrastro al "glulxe.exe". Sin embargo no puedo ejecutar .z5, z8 ni blorb.


Vale, entonces es cosa mía, algo en mi PC no le gusta a glulxe. Lo de que de el error ese de pedir el nombre de la aventura si lo ejecutas directamente es normal en el glulxe de gargoyle, que no tiene menú ni nada parecido para cargar desde dentro, pero que se la pegue como se la pega en mi PC, no es normal. Haré pruebas a ver. Gracias!


PD: El auto-spoiler que has hecho con lo del famoso tesoro y las patrañas de marineros borrachos nos deja con ganas de ver más :-D

_________________
Sígueme en twitter: @uto_dev
http://www.ngpaws.com


Arriba
 Perfil  
 
NotaPublicado: 12 Abr 2016 14:04 
Desconectado
Implementador
Implementador

Registrado: 13 Feb 2005 18:57
Mensajes: 1855
edlobez escribió:
[...]cuando lo arrastro al "glulxe.exe". Sin embargo no puedo ejecutar .z5, z8 ni blorb.

Glulxe no es un intérprete de Z.


Arriba
 Perfil  
 
NotaPublicado: 12 Abr 2016 18:21 
Desconectado
Momio
Momio
Avatar de Usuario

Registrado: 09 Mar 2004 16:14
Mensajes: 4614
He probado glulxe en otra máquina con Win10 y funciona correctamente, así que volveré a poner glulxe en Superglús y ya miraré que pasa con mi máquina. Gracias por la ayuda.

_________________
Sígueme en twitter: @uto_dev
http://www.ngpaws.com


Arriba
 Perfil  
 
NotaPublicado: 20 Abr 2016 08:06 
Desconectado
Implementador
Implementador

Registrado: 09 Jun 2010 14:50
Mensajes: 1601
Ubicación: Argentina
Sólo por sugerir, ¿depende el Glulxe de Gargoile de algún componente en desuetudo como DirectDraw o .Net Framework de 1.1 a 3.5 que ya Microsoft considera viejos? Lo digo porque, si es así, he visto casos en que algunos de estos componentes en Windows 10 están desactivados por defecto, sobre todo si en vez de actualizar desde Windows 7 se instala limpio o se usa la opción Restablecer este PC.


Arriba
 Perfil  
 
NotaPublicado: 20 Abr 2016 08:45 
Desconectado
Momio
Momio
Avatar de Usuario

Registrado: 09 Mar 2004 16:14
Mensajes: 4614
Fernando Gregoire escribió:
Sólo por sugerir, ¿depende el Glulxe de Gargoile de algún componente en desuetudo como DirectDraw o .Net Framework de 1.1 a 3.5 que ya Microsoft considera viejos? Lo digo porque, si es así, he visto casos en que algunos de estos componentes en Windows 10 están desactivados por defecto, sobre todo si en vez de actualizar desde Windows 7 se instala limpio o se usa la opción Restablecer este PC.


Desinstalé algunos programas que había instalado para probar, y volvió a funcionar Glulxe. Sinceramente no se qué podía ser, posiblemente alguna dependencia con versión incorrecta como dices, pero fuera lo que fuera ya está arreglado.

_________________
Sígueme en twitter: @uto_dev
http://www.ngpaws.com


Arriba
 Perfil  
 
NotaPublicado: 22 Abr 2016 12:18 
Desconectado
Implementador
Implementador

Registrado: 09 Jun 2010 14:50
Mensajes: 1601
Ubicación: Argentina
Uto escribió:
pero fuera lo que fuera ya está arreglado.


Pues me alegro que lo hayas podido solucionar. Hubiera sido interesante poder contar con registros a efectos de referencia para usuarios que tengan un problema similar en el futuro, pero comprendo lo impreciso de estos errores de bajo nivel y que consultarlos en los eventos no siempre es lo aclarador que debería.
De todas formas, pensándolo bien, si se tratare de dependencias conocidas como las que cito sin duda estarán en la página oficial de requisitos de Gargoile o en algún material de ayuda afín, y sabiendo la dependencia específica no es difícil, aun si uno no entiende mucho, buscar información en Internet.


Arriba
 Perfil  
 
Mostrar mensajes previos:  Ordenar por  
Nuevo tema Responder al tema  [ 12 mensajes ] 

Todos los horarios son UTC + 1 hora


¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 3 invitados


No puede abrir nuevos temas en este Foro
No puede responder a temas en este Foro
No puede editar sus mensajes en este Foro
No puede borrar sus mensajes en este Foro

Buscar:
Saltar a:  
Desarrollado por phpBB® Forum Software © phpBB Group
Traducción al español por Huan Manwë para phpBB-Es.COM